configuring a 3 button mouse.

Dan Nicholson dbn.lists at
Mon Jun 7 12:25:22 PDT 2010

On Mon, Jun 7, 2010 at 12:21 PM, Geoffrey <lists at> wrote:
> I recently upgraded my Mandriva install and now it appears that my 3 button
> mouse is emulating a 2 button mouse as cut/paste only works when I select
> buttons 1 and 3, but not with button 2.
> The middle button is a wheel and scrolling does work with it, which leads to
> more confusion.
> This has always 'just worked' so it's been a while since I tried to
> configure this.  my xorg.conf looks right (to me):
> Section "InputDevice"
>    Identifier "Mouse1"
>    Driver "mouse"
>    Option "Protocol" "ExplorerPS/2"
>    Option "Device" "/dev/mouse"
>    Option "Emulate3Buttons"
>    Option "Emulate3Timeout" "50"
>    Option "EmulateWheel"
>    Option "EmulateWheelButton" "2"
> EndSection
> Any suggestions would be appreciated.

Can you the log so we can see what's going on? My guess is the device
isn't using the mouse driver like you think it is.


More information about the xorg mailing list