configuring a 3 button mouse.

Geoffrey lists at
Mon Jun 7 12:54:38 PDT 2010

Dan Nicholson wrote:
> On Mon, Jun 7, 2010 at 12:21 PM, Geoffrey <lists at> wrote:
>> I recently upgraded my Mandriva install and now it appears that my 3 button
>> mouse is emulating a 2 button mouse as cut/paste only works when I select
>> buttons 1 and 3, but not with button 2.
>> The middle button is a wheel and scrolling does work with it, which leads to
>> more confusion.
>> This has always 'just worked' so it's been a while since I tried to
>> configure this.  my xorg.conf looks right (to me):
>> Section "InputDevice"
>>    Identifier "Mouse1"
>>    Driver "mouse"
>>    Option "Protocol" "ExplorerPS/2"
>>    Option "Device" "/dev/mouse"
>>    Option "Emulate3Buttons"
>>    Option "Emulate3Timeout" "50"
>>    Option "EmulateWheel"
>>    Option "EmulateWheelButton" "2"
>> EndSection
>> Any suggestions would be appreciated.
> Can you the log so we can see what's going on? My guess is the device
> isn't using the mouse driver like you think it is.

I think you're onto something.  I see this:

(==) The core pointer device wasn't specified explicitly in the layout.
         Using the first mouse device.

I've attached both my xorg.conf and the log for further insights.

Until later, Geoffrey

"I predict future happiness for America if they can prevent
the government from wasting the labors of the people under
the pretense of taking care of them."
- Thomas Jefferson
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: xorg.conf
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: text/x-log
Size: 26860 bytes
Desc: not available
URL: <>

More information about the xorg mailing list