configuring a 3 button mouse.

Geoffrey lists at
Mon Jun 7 12:21:56 PDT 2010

I recently upgraded my Mandriva install and now it appears that my 3 
button mouse is emulating a 2 button mouse as cut/paste only works when 
I select buttons 1 and 3, but not with button 2.

The middle button is a wheel and scrolling does work with it, which 
leads to more confusion.

This has always 'just worked' so it's been a while since I tried to 
configure this.  my xorg.conf looks right (to me):

Section "InputDevice"
     Identifier "Mouse1"
     Driver "mouse"
     Option "Protocol" "ExplorerPS/2"
     Option "Device" "/dev/mouse"
     Option "Emulate3Buttons"
     Option "Emulate3Timeout" "50"
     Option "EmulateWheel"
     Option "EmulateWheelButton" "2"

Any suggestions would be appreciated.

Until later, Geoffrey

"I predict future happiness for America if they can prevent
the government from wasting the labors of the people under
the pretense of taking care of them."
- Thomas Jefferson

More information about the xorg mailing list