xserver-xorg-input-synaptics multiple finger

Peter Hutterer peter.hutterer at who-t.net
Mon Feb 16 17:08:07 PST 2009

On Tue, Feb 17, 2009 at 12:30:26AM +0000, Kalman KHIRALY wrote:
> I buyed today a toshiba l300-19j laptop, with synaptics touchpad.
> I wanted to use multiple finger feature like on macosx.
> It looks like everything is ok:
> 1. the kernel recognizes:
> [  231.424535] input: SynPS/2 Synaptics TouchPad as
> /devices/platform/i8042/serio1/input/input8
> 2. X.org recognizes:
> (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad"
> (type: TOUCHPAD)
> 3. synclient claims two finger support:
> synclient -l |grep VertTwoFingerScroll
>     VertTwoFingerScroll     = 1

This just means it's enabled, nothing more.

> However, when I run synclient -m 100, the "f" column has only 0 or 1, no matter
> with how many finger I touch the touchpad.
> I have googled the whole day, I browsed the source, even read some
> marketing stuff from synaptics website,
> still no success.


> So my question is, how can I make sure, if it is a HARDWARE
> LIMITATION, or some software lack/bug/anything?
> Is there a reliable method to check if my hardware supports multiple
> finger touch or not?

There's some devices that announce multi-finger capabilities even if they
don't actualy do multi-finger. This is a kernel bug, fixed in 2.6.29.
Chances are you have one of them.



More information about the xorg mailing list