xserver-xorg-input-synaptics multiple finger

Kalman KHIRALY khiraly123 at gmx.net
Mon Feb 16 16:30:26 PST 2009


I buyed today a toshiba l300-19j laptop, with synaptics touchpad.
I wanted to use multiple finger feature like on macosx.

It looks like everything is ok:
1. the kernel recognizes:
[  231.424535] input: SynPS/2 Synaptics TouchPad as

2. X.org recognizes:
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad"
(type: TOUCHPAD)

3. synclient claims two finger support:
synclient -l |grep VertTwoFingerScroll
    VertTwoFingerScroll     = 1

However, when I run synclient -m 100, the "f" column has only 0 or 1, no matter
with how many finger I touch the touchpad.

I have googled the whole day, I browsed the source, even read some
marketing stuff from synaptics website,
still no success.

I have found a hardware compatibility list:

I seems outdated, I do not see any Toshiba L300 model on the list.
I couldnt find any newer compatibility list, is such exists?

So my question is, how can I make sure, if it is a HARDWARE
LIMITATION, or some software lack/bug/anything?
Is there a reliable method to check if my hardware supports multiple
finger touch or not?

I read everywhere that newer synaptics touchpads should not have any problems.

Any idea is much appreciated!

My system details:
Ubuntu 9.04 alpha 4 live dvd, with hand installed:

kernel (uname -a):
Linux ubuntu 2.6.28-6-generic #17-Ubuntu SMP Fri Jan 30 15:34:36 UTC
2009 i686 GNU/Linux

xorg.conf (I only pasted the following paragraph into xorg.conf):
Section "InputDevice"
        Identifier      "SynPS/2 Synaptics TouchPad"
        Driver          "synaptics"
        Option          "CorePointer"
        Option          "Device"              "/dev/psaux"
        Option          "Protocol"            "auto-dev"
        Option          "SHMConfig"           "true"
        Option          "MaxTapTime"          "0"
	Option 		"VertTwoFingerScroll" "1"
	Option 		"HorizTwoFingerScroll" "1"

Full xorg.conf can be found here:

/proc/cpuinfo here:

dmesg here:

Xorg.0.log here:

lspci here:

lspci -vvvnnn here:

If there is any more additional information you need, just reply, I
will post them.

Im mainly interested to figure out if it is a hardware limitation (I
have two days left for this;)

Thank you in advance,

 Best regards,

More information about the xorg mailing list