radeonhd blank screens

tsuraan tsuraan at gmail.com
Mon Dec 7 06:21:34 PST 2009

> sw info:
> xorg-server
> libdrm 2.4.13
> mesa 7.5.1
> xf86-video-radeonhd 1.3.0
> xf86-video-ati 6.12.4 (not used, but I read it was necessary for
> radeonhd to work)
> linux kernel 2.6.32

Some updates:

I've tried upgrading my software to:
xorg-server 1.7.3
libdrm development
mesa development
xf86-video-ati development

And I still get the same blank screen.  I have noticed that I can
switch back to the controlling vt of X using the normal ctrl+alt+F1
combination, so X is at least that responsive.  X's terminal just
shows the unknown HDMI output type error and an error about my
keyboard, so it's not too interesting.  If I SIGINT X from its
terminal, though, I get another error:

(EE) RADONHD(0): RHDCSStop: Command Submission backend is not active!

I don't know what that means, but it sounds like it could explain why
I'm not getting any video.  Does anybody have a clue as to why the CS
backend wouldn't be active?

More information about the xorg mailing list