radeonhd blank screens

tsuraan tsuraan at gmail.com
Sun Dec 6 20:13:20 PST 2009

I just picked up a new radeon 4650 with two dvi ports to replace my
previous card, but I'm having some troubles.  Basically, the radeon
appears to work perfectly in console mode (even if I try KMS), but
when I try to start X, it blanks both screens and never progresses
from there.  no window manager is started, my X process has no child
processes, strace just gives an endless loop of these six lines:

select(256, [1 3 4 6 9], NULL, NULL, {0, 100000}) = 0 (Timeout)
setitimer(ITIMER_REAL, {it_interval={0, 20000}, it_value={0, 20000}}, NULL) = 0
clock_gettime(CLOCK_MONOTONIC, {168, 140116685}) = 0
clock_gettime(CLOCK_MONOTONIC, {168, 140157191}) = 0
clock_gettime(CLOCK_MONOTONIC, {168, 140193508}) = 0
setitimer(ITIMER_REAL, {it_interval={0, 0}, it_value={0, 0}}, NULL) = 0

although the second value following the 167 in the clock_gettime seems
to vary randomly, and moving the mouse gives some other lines about
rt_sigprocmask calls and read calls.

The Xorg.0.log only has errors of unknown HDMI output type (apparently
harmless) and the fact that I don't have r600_dri.so installed (not
sure how to get it, 3D isn't important right now anyhow).

If I reboot my machine while X has been started by hand from a
physical terminal (not over ssh), then after the reboot broadcast, X
does start working, or at least it gives my the "X" cursor, which
moves around when I move my mouse.  That log file is attached as
Xorg.0.log.worked.  It starts the same as my normal log file, but
half-way down there's a stanza about UnloadModule: "evdev", and then
apparently the same setup sequence that the radeonhd driver did at the
top of the file, but after all of that, I get a responsive "X" cursor
for a few moments before my system reboots.  Prior to issuing the
reboot, I had no cursor, just a blank screen, so that moment of
functional cursor seems to be a stop in the right direction.

hw info:
radeon HD 4650 (RV730?) with two DVI ports
two monitors, 1600x900, both connected via DVI

sw info:
libdrm 2.4.13
mesa 7.5.1
xf86-video-radeonhd 1.3.0
xf86-video-ati 6.12.4 (not used, but I read it was necessary for
radeonhd to work)
linux kernel 2.6.32

Attached are my kernel .config, my xorg.conf, and my Xorg.0.log and
Xorg.0.log.worked files.  I'm really hoping somebody can help me out
so that I can stop trying to use my nVidia card with KDE4.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config-2.6.32
Type: application/octet-stream
Size: 64361 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20091206/1d30ccb3/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: text/x-log
Size: 46201 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20091206/1d30ccb3/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.conf.new
Type: application/octet-stream
Size: 3035 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20091206/1d30ccb3/attachment-0001.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log.worked
Type: application/octet-stream
Size: 57882 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20091206/1d30ccb3/attachment-0002.obj>

More information about the xorg mailing list