xorg build problems: dtrace script

Chuck Robey chuckr at telenix.org
Thu Jun 19 05:41:27 PDT 2008

Hash: SHA1

Chuck Robey wrote:
> Chuck Robey wrote:
>> Adam K Kirchhoff wrote:
>>> You can get the build to work by completely disabling the use of dtrace
>>> with --without-detrace passed to ./configure, iirc.  
> I just tried that from the top using CONFFLAGS, it fails.  it's late here, I'll
> try it from the dix dir tomorrow.  Either way, it's a failure, so I'll both be
> interested why it doesn't know what a uid_t is, and also why it doesn't react to
> CONFFLAGS.  The only question is whether it works if it gets that flag locally.
>>> I have noticed that this is only necessary on FreeBSD/amd64.  It works
>>> fine with FreeBSD/i386.

Asking on the FreeBSD-current mailing list got me a referenmce to a mail by John
Birrel, a recent one, howing that they have disabled dtrace in ALL of their X
ports (not only amd64, x86 also).  I would suggest that it makes a lot more
sense, temporarily, for the xorg build to block this directly, for all FreeBSD.
 Not that it matters to me, now that I know the answer, I'll get past this.

>> OK, I haven't done much diagnosing yet, but the pr9oblem I ad was on a i386
>> runnning FreeBSD-current, not the amd64.  Can't read too much into that until I
>> know more of why it didn't know what a uid_t was.
>>> Adam
>>> On Wed, 18 Jun 2008 18:02:53 -0400
>>> Chuck Robey <chuckr at telenix.org> wrote:
>>> Alan Coopersmith wrote:
>>>>>> Chuck Robey wrote:
>>>>>>> I've never seen this type of thing before.  Is it a precompiler of
>>>>>>> some sort? It's getting an error, looks like it's tripping over a
>>>>>>> common FreeBSD type, a uid_t.  I know how I'd handle this with a C
>>>>>>> file, I'd find out where it was defined, see if it was already
>>>>>>> included but had define masking problems, or if it just plain
>>>>>>> wasn't included before, and then add an include for it, but I
>>>>>>> don't know what the heck this thing is ... code is /usr/lib??
>>>>>>> that's wacky ...
>>>>>>> Anyhow, here's the last part of the error listing (from
>>>>>>> xserver,dix).  If you don't recognize the error, but know
>>>>>>> something about the .d files, you could tell me, then I could
>>>>>>> pester the FreeBSD folks about it:
>>>>>>> ranlib .libs/libdix.a
>>>>>>> creating libdix.la
>>>>>>> (cd .libs && rm -f libdix.la && ln -s ../libdix.la libdix.la)
>>>>>>> /usr/sbin/dtrace -G -C -o dtrace-dix.o
>>>>>>> -s ../dix/Xserver.d .libs/*.o dtrace: failed to compile
>>>>>>> script ../dix/Xserver.d: "/usr/lib/dtrace/psinfo.d", line 37:
>>>>>>> syntax error near "uid_t"
>>>>>> In that step, the dtrace program is using the information in the
>>>>>> Xserver.d text file to post-process the binaries to insert the
>>>>>> dtrace probe points.    I don't know if anyone has tried building
>>>>>> on FreeBSD with the dtrace probes since those were just integrated
>>>>>> to the FreeBSD kernel, and would have to check with the guys who
>>>>>> did the dtrace port to FreeBSD to see if there's anything different
>>>>>> we need to do there.   (I know MacOS X needs changes to the dtrace
>>>>>> routines, but I've never gotten to a Leopard machine to fix them,
>>>>>> and the Apple guys working on X have had a lot of higher priority
>>>>>> things to fix first.)
>>> Fine, that's enough info for me to make the rest of the way on my own.
>>> Appreciate it.
>> _______________________________________________
>> xorg mailing list
>> xorg at lists.freedesktop.org
>> http://lists.freedesktop.org/mailman/listinfo/xorg
> _______________________________________________
> xorg mailing list
> xorg at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/xorg
xorg mailing list
xorg at lists.freedesktop.org

Version: GnuPG v2.0.4 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the xorg mailing list