Feedback from latest Intel drivers / xserver

Keith Packard keithp at
Mon Mar 5 19:48:00 PST 2007

On Tue, 2007-03-06 at 14:37 +1100, Daniel Kasak wrote:
> Greetings.
> I've just updated to the latest stuff ( xserver-,
> xf86-video-intel from git, drm from git, mesa-6.5.2, 2.6.19 kernel ) and
> done some limited testing.

Thanks for your help; getting this stuff stable before release is our
goal at this point.

> Firstly, I was unable to get direct rendering working ( yes I'm *sure* I
> had the latest drm ). I'm not sure if the rest of the problems hinge on
> this or not.

Not likely; DRM is only needed for 3D.

> Next, I tried running 'xcompmgr -Ff' ( with EXA enabled ). This turned
> out to be an order of magnitude slower than with XAA, which is actually
> usable on this integrated chip ( i845G ).
> Next, I tried switching Enlightenment-0.17 to use the XRENDER engine.
> This immediately crashed the X server, with:

Now, that's a bug I've been trying to reproduce for a long time. Is this
reproducible at will? Explicit instructions for making this happen would
be very welcome at this stage; I'm only seeing this when I VT switch
back to X once every 10 or 20 times.

keith.packard at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the xorg mailing list