Feedback from latest Intel drivers / xserver

Daniel Kasak dan at
Mon Mar 5 19:37:43 PST 2007


I've just updated to the latest stuff ( xserver-,
xf86-video-intel from git, drm from git, mesa-6.5.2, 2.6.19 kernel ) and
done some limited testing.

Firstly, I was unable to get direct rendering working ( yes I'm *sure* I
had the latest drm ). I'm not sure if the rest of the problems hinge on
this or not.

Next, I tried running 'xcompmgr -Ff' ( with EXA enabled ). This turned
out to be an order of magnitude slower than with XAA, which is actually
usable on this integrated chip ( i845G ).

Next, I tried switching Enlightenment-0.17 to use the XRENDER engine.
This immediately crashed the X server, with:


pgetbl_ctl: 0x2ffe0001 pgetbl_err: 0x0
ipeir: 0 iphdr: 9020c0
LP ring tail: 458 head: 3b8 len: 1f001 start 0
eir: 0 esr: 0 emr: ff7b
instdone: ffc1 instpm: 0
memmode: 0 instps: 2c
hwstam: effe ier: 82 imr: 53c iir: 41
space: 130904 wanted 131064

Fatal server error:

(EE) intel(0): I830 Vblank Pipe Setup Failed 0
(EE) intel(0): I830 Vblank Pipe Setup Failed 0


At this point I should also mention that each time I had an xserver
crash, I had to reboot before I could start X again, otherwise I'd get:


(WW) intel(0): PRB0_HEAD (0x000003b8) and PRB0_TAIL (0x00000000)
indicate ring buffer not flushed
(WW) intel(0): Existing errors found in hardware state.


 ... and it would immediately crash again.

After rebooting, I've tried starting Enlightenment with the XRENDER
engine ( I can't get into it to set it back to software ), and it does
the same thing each time. I assume EXA / XRENDER isn't complete / stable

I'm pretty much out of time for testing at the moment ... have to
quickly install xserver-1.2 and get some work done.

Full X log and xorg.conf attached.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log
Type: text/x-log
Size: 75388 bytes
Desc: not available
URL: <>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: xorg.conf
URL: <>

More information about the xorg mailing list