xvfb-run seems to start command too early

Samuel Thibault samuel.thibault at ens-lyon.org
Mon Nov 4 19:39:02 UTC 2019


Yannick Schinko, le lun. 04 nov. 2019 14:25:43 +0000, a ecrit:
> When using xvfb-run (1.19.2-1+deb9u5) to run gource headless I run into the issue that the underlying server does not seem to be ready in time a good 75+% of cases.

Note that the xvfb-run script is a Debian script (thus Cc-ing
maintainers there just for information), but possibly the issue is
inside the Xserver, see below.

> In those cases gource complains:
> gource: SDL initialization failed - Couldn't find matching GLX visual
> Now this suspicion is amplified because when I run it as "xvfb-run <args...> bash -c "sleep 1; gource <args...>" it works every time.
> Is there some way to work around this issue other than having a sleep before the gource command (which would make working with some scripts a pain)?

It happens that the Debian xvfb-run script takes good care of using
SIGUSR1 to synchronize with Xvfb (see SIGUSR1 in man Xserver), so I'm
surprised that you're running into issues. Perhaps the X server is
sending SIGUSR1 too early?


More information about the xorg mailing list