display/GFX issue with Ubuntu 16.04 not seen in 14.04

Jim Abernathy jfabernathy at outlook.com
Wed Aug 24 12:10:36 UTC 2016

On 08/24/2016 07:16 AM, Jim Abernathy wrote:
> On 08/23/2016 10:33 AM, Christopher Barry wrote:
>> On Tue, 23 Aug 2016 06:53:13 -0400
>> Jim Abernathy <jfabernathy at outlook.com> wrote:
>>> On 08/19/2016 10:17 AM, Jim Abernathy wrote:
>>>> Not having much luck with the Distro forums on this issue so I
>>>> thought I'd ask for advice here.
>>>> I've been running Ubuntu 14.04.5 for some time on Intel Core i5 GFX
>>>> without any issues.  My display is HDMI from the PC to an Onkyo A/V
>>>> receiver then to a Sony KDL-XBR6.
>>>> When I try a fresh install of 16.04.1, I get a display that blanks
>>>> out for 3-5 seconds at random times depending on what is being
>>>> displayed at the time.  I also have small abouts of video noise that
>>>> is random horizontal lines about 1 pixel tall scattered through the
>>>> page.
>>>> I noticed that 14.04.05 uses X server 1.17.2 and 16.04.1 uses 1.18.3.
>>>> When I do the command xrandr --verbose I see some small differences
>>>> between 14.04 and 16.04, but it's things like 2 digits displayed
>>>> instead of 1.  i.e. 60.0 vs. 60.00. I'm only concerned with 1080P HD.
>>>> I've tried this on different computers all with Intel GFX. same
>>>> results.
>>>> This does not occur on other monitors or TVs.
>>>> I'd blame it on Sony and Onkyo if they didn't work so well with
>>>> Windows, all versions, and ubuntu all versions except 16.04.
>>>> It's almost like the auto detection software in the newest version
>>>> of X is off just enough to make my display flaky.  Kind of like the
>>>> old analog CRT TVs that were sensitive to small tweaks to the
>>>> horizontal and vertical adjustments.
>>>> Any help would be appreciated.
>>>> Jim A
>>> Can someone let me know where I can ask questions regarding problems
>>> with X??  I thought this forum would be the place?
>>> Jim A
>> Jim,
>>  From the data above, I do not think it's possible to troubleshoot very
>> effectively. It also seems like (to me anyway) that you have a fairly
>> non-standard kind of configuration going on.
>> If I understand it, you have a media-center type PC with an integrated
>> Intel graphics card on an core i5 processor. Using an HDMI cable, you're
>> plugging into an Onkyo A/V receiver (you do not mention the model),
>> which in turn connects to a Sony KDL-XBR6 LCD TV.
>> What happens when you connect your PC to a the Sony directly or to
>> a normal PC LCD monitor? Does that work?
>> Are you using an xorg configuration file, or are you allowing automatic
>> setup via kernel mode switching? If you a have config file(s), what
>> happens when you move them out of the way temporarily and allow
>> automatic config?
> I'm using automatic setup on install. I played with the concept of 
> creating an xorg.conf file. It's not as easy as it used to be.  I 
> tried without success to create an entry with a modeline statement but 
> it messed things up so I abandoned that path of debug.
>> What's in your /var/log/Xorg.0.log?
> I'll post the Xorg log later when I'm back at that PC.  I looked at it 
> to confirm no errors and which xorg configuration file it was using.  
> I'll post one from my test system that has nothing but 16.04 installed 
> plus current updates.

Below is the part of dmesg related to Intel:
jim at test:~$ dmesg | grep intel
[    1.504215] intel_idle: MWAIT substates: 0x21120
[    1.504218] intel_idle: v0.4.1 model 0x2A
[    1.504221] intel_idle: lapic_timer_reliable_states 0xffffffff
[    2.891286] fb: switching to inteldrmfb from EFI VGA
[    3.190749] fbcon: inteldrmfb (fb0) is primary device
[    3.190970] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    6.280413] snd_hda_intel 0000:00:1b.0: enabling device (0000 -> 0002)
[    6.601171] intel_rapl: Found RAPL domain package
[    6.601179] intel_rapl: Found RAPL domain core
[    6.601183] intel_rapl: Found RAPL domain uncore
[   37.185938] [drm:intel_set_pch_fifo_underrun_reporting [i915]] 
*ERROR* uncleared pch fifo underrun on pch transcoder A
[   37.185988] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* 
PCH transcoder A FIFO underrun

Here is the xorg.log

>> People here help quite readily if they have data to act upon.
>> -- 
>> Regards,
>> Christopher Barry
>> _______________________________________________
>> xorg at lists.x.org: X.Org support
>> Archives: http://lists.freedesktop.org/archives/xorg
>> Info: https://lists.x.org/mailman/listinfo/xorg
>> Your subscription address: %(user_address)s
> _______________________________________________
> xorg at lists.x.org: X.Org support
> Archives: http://lists.freedesktop.org/archives/xorg
> Info: https://lists.x.org/mailman/listinfo/xorg
> Your subscription address: %(user_address)s

-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.log
Type: text/x-log
Size: 21129 bytes
Desc: not available
URL: <https://lists.x.org/archives/xorg/attachments/20160824/c1b8b542/attachment.bin>

More information about the xorg mailing list