double-tap and hold touchpad behavior

Brandon Casey drafnel at
Mon Aug 22 21:24:38 PDT 2011

On Fri, Aug 19, 2011 at 1:15 AM, Peter Hutterer <peter.hutterer at>wrote:

> On Wed, Aug 17, 2011 at 10:16:18PM -0500, Brandon Casey wrote:
> > Please let me know if this is the wrong place to post this message.
> >
> > For a long time now I have been missing the old method that I used to use
> to
> > highlight text, drag-and-drop, and move windows around.  I used to be
> able
> > to produce a button press-and-hold by performing a double-tap and hold
> (tap
> > twice on touchpad, but leave the finger resting on the touchpad on the
> > second tap).  But with recent distributions the last few years, that
> doesn't
> > work.  Now, it seems, you have to double-tap, hold, and drag.
> >
> > Is there any way to re-enable the old double-tap-and-hold instead of the
> > double-tap-and-drag?
> this probably doesn't help but I've just tried it here and it worked fine.
> you can disable it by unsetting the Synaptics Gestures property but it is
> enabled by default.

So, when you double-tap-and-hold on a window title bar, without moving
the mouse after the second tap (i.e. no "drag" gesture), your pointer grabs
the title bar and the mouse icon changes to indicate that?

Just to make sure you understood me (and I you), when I do the
above, nothing happens.  It doesn't even produce an event in xev.

The double-tap-and-drag gesture does work, but for that one, you have
to drag your finger after the second tap (touch-release-touch-drag).
 The Synaptics Gestures property controls this feature.  If I disable it,
then it disables double-tap-and-drag, but it doesn't enable
double-tap-and-hold.  You then have to use the
physical buttons.

I would like to enable the tap-and-hold functionality, but I don't know
how to get it.  Maybe there is an alternative touchpad driver other than
the synaptics one?  If so, how do I disable the synaptics driver and just
use the standard one?

I'm using fedora-15, and fedora 13 before it.  What distribution are
you using?

Also, this touchpad works correctly in windows.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list