X server crashing

courten at web.de courten at web.de
Fri Aug 12 14:12:23 PDT 2011

have you freshly compiled gcc?

which version of libc do you use?

-----Ursprüngliche Nachricht-----
Von: "Chris Robinson" <fabricator4 at yahoo.com>
Gesendet: 12.08.2011 22:23:59
An: "xorg at lists.freedesktop.org" <xorg at lists.freedesktop.org>
Betreff: X server crashing

Hi, I'm hoping someone can help as I haven't got much hair left.


I've installed Slackware 13.37 on a spare PC (Celeron 2.8GHz, 1Gb RAM, ATI Rage 128 video card) and everything went well after a moderately steep learning curve.  I could start kde and use it.  However, I'm running this system and another (Ubuntu LTS) through a KVM switch which adds a complication in that it does not appear to pass the monitor (Samsung 1100p) EDID data to the video card so most default installs have trouble getting resolutions higher than 800x600.

Under Ubuntu I found I could solve this quite easily by adding the following to my the monitor section in /etc/X11/xorg.conf:
Horizsync    30-96
Vertrefresh    50-160

Note that the monitor is actually capable of 1600x1200, but I use these parameters because it gives me a maximum resolution of the monitors ideal settings which is 1280x1024 at 85Hz and a new install therefore defaults to this.  In the past I've had absolutely NO luck with specifying modeset lines etc - they just seem to be ignored.

To attempt to get the higher resolution under Slackware I ran 'Xorg -configure' to generate the xorg.conf.new and moved it to /etc/X11/xorg.conf.  I then added the two lines above.  When I run startx, KDE starts up in high resolution mode (Yay!) and looks great, but before it's finished fully loading it crashes.  The following appears to be the section in the log where it all starts to go pear shaped:

[  5487.564] 18: /lib/libc.so.6 (__libc_start_main+0xe6) [0xb7384db6]
[  5487.564] 19: /usr/bin/X (0x8048000+0x1aaa1) [0x8062aa1]
[  5487.564] Segmentation fault at address (nil)
[  5487.564]
Fatal server error:
[  5487.564] Caught signal 11 (Segmentation fault). Server aborting
[  5487.564]
[  5487.564]

It then crashes out with many subsequent error messages, finally complaining that it can't find screen:0

I've tried the bare-bones xorg.conf that works with my Ubuntu systems (actually, tried that first) and I've tried using modeset instead of Horizsync and Vertrefresh despite the fact that it's never worked for me before and is much more complicated.

I find it interesting that it the correct resolution is identified (verified in the log) and actually starts up in the correct mode, but then crashes out.

I will post the full logs and xorg.conf if it's requested, but I didn't want to bombard the list on my first post - I think I got the essence of the problem however.


xorg at lists.freedesktop.org: X.Org support
Archives: http://lists.freedesktop.org/archives/xorg
Info: http://lists.freedesktop.org/mailman/listinfo/xorg
Your subscription address: courten at web.de

Schon gehört? WEB.DE hat einen genialen Phishing-Filter in die
Toolbar eingebaut! http://produkte.web.de/go/toolbar

More information about the xorg mailing list