xorg can't load qxl driver

Brian Milliron brianm at io.com
Wed Jun 9 16:55:55 PDT 2010

> if you don't know how to apply a patch, you may just delete following line 
> in src/qxl_driver.c line 1234, then recompile it 
>     assert (((struct qxl_mode *)p->Private)->x_res == p->HDisplay);
>     assert (((struct qxl_mode *)p->Private)->y_res == p->VDisplay);

Really?  All those source files and the only thing they do is remove 2
lines?  I tried using nano to remove the 2 lines you note and recompiled
the drivers.  Now when x windows starts it crashes my whole ubuntu.  I
logged into terminal to try and delete the bad drivers but when I use cd
/usr/lib/xorg/modules/drivers it says that directory doesn't exist.  ls
shows the whole /usr/lib/ directory is different than the last time I
looked at it.  Where did all my files go?

>> 2) His statement that "QXL Driver is included in debian unstable, you
>> may build it for you ubuntu."
>> Does he mean these drivers are unstable?
>> http://xorg.freedesktop.org/releases/individual/driver/xf86-video-
> qxl-0.0.12.tar.gz
>> Because those are the ones I currently have installed.
>> I tried using the ones he linked to here:
>> http://ftp.de.debian.org/debian/pool/main/x/xserver-xorg-video-
>> qxl/xserver-xorg-video-qxl_0.0.12-1.dsc
>> But they require xserver-xorg-dev version which I don't know
>> where to get.
> you have not install xserver-xorg-dev, so you may not compile the dpkg 
> package.  if the first methord works, please forgot this one. 

Actually I do have xserver-xorg-dev installed just not version
which is the requirement.  I have the latest version installed which is
all that apt-get will give me the option to install.  I have no idea
where to get the version I need for the package.


More information about the xorg mailing list