[xf86-video-intel] G35, 1280x720 and close but not exact refresh rates

Petri Helin phelin at googlemail.com
Tue Sep 16 14:04:15 PDT 2008


I have a Asus P5E-V HDMI motherboard with G35 integrated graphics 
connected with HDMI to Sanyo PLV-Z4 projector. I am trying to get 
1280x720 work with both 50Hz and 60Hz. But all I can manage is 50.1Hz 
and 60.1Hz as reported by the projector.

I started with these modelines:

# 1280x720p @ 60Hz (EIA/CEA-861B)
ModeLine "1280x720" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
# 1280x720p @ 50Hz (EIA/CEA-861B)
ModeLine "1280x720" 74.250 1280 1720 1760 1980 720 725 730 750 +hsync +vsync

Those are the ones giving me 50.1Hz and 60.1Hz. I have tried to reduce 
the pixel clock, but it jumps from 50.1 to 49.9 missing 50.0 altogether. 
I previously used Nvidia 7300GS with the same modelines, same HDMI cable 
and same projector. And with Nvidia I got 50.0 dead. I have tried both 
the drivers coming with Ubuntu Intrepid Ibex (2.4.1+patches) and 2.4.2.

So, I'd like to know if anyone else is experiencing the same. Or, if 
someone had a solution, it would be even better ;)


More information about the xorg mailing list