2.6.27-rc5 radeon kernel module can't load r300_dri.so - help?

Lars Oliver Hansen lolh at ymail.com
Wed Sep 10 10:39:22 PDT 2008


> If you've just installed packages, then uninstalling fglrx is fine.  If
> you 
installed it manually, you'll need to reinstall Mesa from the
> packages also 
(sudo apt-get install --reinstall libgl1-mesa-glx 
> Debian/Ubuntu).
> 'libGL' in this sense refers to libGL.so (usually 
in /usr/lib).
> Cheers,
> Daniel

This solved it, thanks!

Now, there is no need for booting the old kernel anymore. Still, I tried that and instead of the login screen the screen remains black and ctrl+alt+f1 doesn't show the console. This can be an issue with a problematic setting in xorg.conf (such as Option "DynamicClocks" "true" with the new kernel :-( ). Do you have an idea what could be the cause for this? Kernel is 2.6.24-19-generic from Ubuntu 8.04.1 and drm and radeon modules are available in that kernel drivers/char/drm directory. Everything else is identical to the 2.6.27-rc5 kernel.

I have some questions regarding AIGLX and direct rendering, I will ask them in a seperate e-mail to the list.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20080910/f685c329/attachment.html>

More information about the xorg mailing list