Mouse Issues with evdev driver

Daniel Stone daniel at
Tue Mar 11 09:53:58 PDT 2008

On Tue, Mar 11, 2008 at 06:32:22PM +0200, Khelben Blackstaff wrote:
> 1) I press and hold left click and drag the mouse to copy some text,
> but it behaves as if the left click is released (it seams to me that
> way). For example if i try to copy "Some text to copy" it will copy
> "to copy" or something like that.
> Because i can't describe it well enough i have captured a video of
> my desktop so that you can see what i am saying.
> (1.2MB)
> This behavior occurs only with evdev and not mouse and gpm
> on tty, so it can't be hardware problem.
> My former mouse (logitech mx510) worked fine with evdev, so its some
> issue with this mouse's protocol and evdev i guess.

Pretty sure the problem here is just a lack of debouncing; IMO this
should be kernelside, though it's debateable, and I'm certainly not
opposed to including debouncing support in X.

> 2) Two buttons (named Zoom-,Zoom+) don't produce events in xev.

Can you run evtest to see what keycode they are? Likely, the keycode's
just above 255, which we can't support right now.

> 3) Middle and Right click are reversed in -git version of evdev
> More a notice than an issue. I fixed it with xmodmap.

This is a known issue, and will presumably be fixed soonish.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <>

More information about the xorg mailing list