snapshots between X servers

Adam Jackson ajax at
Tue Mar 4 09:53:53 PST 2008

On Tue, 2008-03-04 at 17:42 +0100, Franck Juers wrote:
> Hello,
> I've tried to do a snapshot of an X server from an other and it
> doesn't work...
> I've got one X server which uses display :0.0
> I've started an other server with "startx -- :8"
> when I'm working on :0.0, if I do "import -window root -display :8
> test.bmp" it doesn't work,
> when I display it, it's not good... but when I do it from the
> server :8.0 with exactly the same command it works...
> I've tried one Xnest -ac :8 &
> when I do the snapshot with the import command it captures :0.0 !!!!
> Someone could explain ?

Hardware servers only have their front buffer while they are active on
the VT.  When they are switched away, they _lose_ video memory.  The
pixels are gone.  There's nothing to capture.

- ajax
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the xorg mailing list