XvMC and Intel G33

Zhenyu Wang zhen78 at gmail.com
Sun Jun 29 16:20:53 PDT 2008

On 2008.06.29 15:14:03 +0200, Tore Anderson wrote:
> ...and the X server log indicates that XvMC is enabled correctly:
> (II) Loading extension XVideo-MotionCompensation
> ...
> (**) intel(0): Intel XvMC decoder enabled

Does your log have a line like "[XvMC] i915_xvmc driver initialized"?
My G33 died last week, I haven't tried to run it recently.

> However mplayer refuses to use -vo xvmc, claiming:
> vo_xvmc: X-Video extension 2.2
> vo_xvmc: No X-Video MotionCompensation Extension on :0.0
> Error opening/initializing the selected video_out (-vo) device.
> I'm running Ubuntu Hardy (x86 version), but have installed the Intel video 
> driver from the developement branch (2.3.2-1ubuntu3), and I believe XvMC is 
> supposed to be supported on the G33 with this version.  I've tried putting 
> both "libIntelXvMC.so" and "/usr/lib/libIntelXvMC.so" in /etc/X11/XvMCConfig, 
> as well as leaving it to the default "libXvMC.so.1".  Doesn't help though, and 
> I'm out of ideas on what to try next.  Any suggestions?

Current driver doesn't require to manually set libIntelXvMC.so path any more.

More information about the xorg mailing list