ATI Radeon X1650 Pro problem

Mohan Parthasarathy suruti94 at
Thu Jun 26 11:19:03 PDT 2008


I installed ATI Radeon X1650 Pro. To get it started, i downloaded the ATI
propreitary driver from
their site (fglrx_drv). It worked fine though i see a number of errors in
the Xorg0.log.

(II) Loading sub module "glx"
(II) LoadModule: "glx"
(II) Reloading /usr/lib/xorg/modules//
(II) Loading extension GLX
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *

I am running 2.6.20-16  and how do i get the right matching kernel drm
module ?
lsmod does show fglrx.  I am wondering why i get this error:

(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found

though lspci does show the card at PCI:1:00:1

I tried using the Xorg drivers. But i get an error like "drvModuleData" not
Finally i want to  run AIGLX, not sure what the right way here is ? Should i
use the proprietary drivers or Xorg drivers ? Also, how do i get the
drm modules ?

thanks a lot,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list