intel crashes on current branches and GM965

Tobias Hain tobias.hain at
Thu Dec 18 23:03:47 PST 2008


The intel module loads fine (dri, dri2, libglx as well):

(II) LoadModule: "intel"
(II) Loading /opt/gfx-test/lib/xorg/modules/drivers//
(II) Module intel: vendor="X.Org Foundation"
	compiled for, module version = 2.5.99
	Module class: X.Org Video Driver
	ABI class: X.Org Video Driver, version 5.0

I even have kdm up and running, but once it loads the KDE 4.1.2 desktop it
crashes. To me it looks like the moment when it loads the 3D compositing
manager and also the stacktrace suggests that.

I missed adding "intel" and GM965 to the subject line in the first place.
That's why I keep the original message attached. Hope somebody recognizes
this one:


2008/12/18 Tobias Hain <tobias.hain at> wrote:
> Hello,
> chipset: GM965
> kernel: (vanilla) 2.6.28-rc8, (drm-intel-next) of Eric's 2.6.28-rc8
> xserver: server-1.6-branch
> libdrm: master
> mesa: master and intel-2008-q4
> xf86-video-intel: xf86-video-intel-2.6-branch
> remaining components: Kubuntu 8.10
> I'm facing crashes when launching X with all of the above:
> Backtrace:
> 0: /opt/gfx-test/bin/Xorg(xorg_backtrace+0x3b) [0x81323fb]
> 1: /opt/gfx-test/bin/Xorg(xf86SigHandler+0x51) [0x80b82a1]
> 2: [0xb7f9b400]
> 3: /opt/gfx-test/lib/dri/ [0xa75c6a08]
> 4: /opt/gfx-test/lib/dri/ [0xa75c712e]
> 5: /opt/gfx-test/lib/dri/ [0xa76647ea]
> 6: /opt/gfx-test/lib/xorg/modules/extensions// [0xb7a40278]
> 7: /opt/gfx-test/lib/xorg/modules/extensions// [0xb7a6a5fb]
> 8: /opt/gfx-test/lib/xorg/modules/extensions// [0xb7a6eb8a]
> 9: /opt/gfx-test/bin/Xorg(Dispatch+0x33f) [0x808cc6f]
> 10: /opt/gfx-test/bin/Xorg(main+0x3bd) [0x807192d]
> 11: /lib/ [0xb7ad3685]
> 12: /opt/gfx-test/bin/Xorg [0x8070de1]
> Fatal server error:
> Caught signal 11.  Server aborting
> It's always the same crash and related to 3D compositing manager loading I
> guess. I tried some permutations of the above branches, but none worked.
> Always the same crash that I didn't have before updating the branches.
> been tracking intel driver development for a while, but not on a regular
> basis. I think I updated branches one month old and before that everything
> worked fine. xorg.conf doesn't contain anything special.
> It's KDE 4.1 compositing manager. Haven't tried anything else yet. Hope it
> sounds familiar to some.
do the drm and intel module load at x startup? i has some similar messages
time ago on radeon caused by modules not autoloading at x startup. i've
them to autoload at startup and then it worked. for some reason after
the 1.5 release
i couldn't start x without them forcedly loaded by the kernel. try
loading the modules
manually and see if something changes.

dott. ing. beso

More information about the xorg mailing list