Building latest Intel support for 945G

Cliff Lawson cliff at
Thu Dec 18 09:31:02 PST 2008



Well it's taken me a while (well a week) to get to this point as I had
to learn all about using git and building the full Xorg set of code. But
in an attempt to see whether Intel 2.5.1 would help the problems I'm
seeing on a 945G based system I did the following:


1)    Pulled/built the mainline 2.6.28-rc8 kernel from
git:// so
I could get 2.6.28-rc8 as I believe (?) this will have the latest drm.ko
and i915.ko (or am I wrong about that?)

2)    Followed the script on the end of the page:
<>  and slowly but surely fixed
any missing dependencies on my system


I did all this first on an Ubunutu 8.04 machine running in a Vmware
sandbox on a Windows machine first just to make sure that I could get
everything to build. Eventually I got it booting 2.6.28-rc8 and running
the X software stack I'd built this way. But clearly the video driver in
this is the Vmware driver - not an Intel hardware driver. So everything
worked in that environment which gave me confidence that I built
everything OK.


I then moved over to the target machine and did it all again. At the end
of this process I tried the same method to start my "private" copy of X
but, as the attached Xorg.0.log shows this ends with:


(II) intel(0): [drm] mapped front buffer at 0x20000000, handle =

(II) intel(0): [drm] mapped back buffer at 0x20000000, handle =

(II) intel(0): [drm] mapped depth buffer at 0x20000000, handle =

(II) intel(0): [drm] mapped classic textures at 0x2dff5000, handle =



0: /usr/bin/X11/X(xf86SigHandler+0x7e) [0x80c780e]

1: [0xb8031400]

2: /usr/local/lib/xorg/modules/drivers// [0xb7bcbc03]

3: /usr/local/lib/xorg/modules/drivers// [0xb7bcd3be]

4: /usr/bin/X11/X(AddScreen+0x1fc) [0x8073d9c]

5: /usr/bin/X11/X(InitOutput+0x21e) [0x80a9c4e]

6: /usr/bin/X11/X(main+0x296) [0x8074526]

7: /lib/tls/i686/cmov/ [0xb7db6450]

8: /usr/bin/X11/X(FontFileCompleteXLFD+0x201) [0x8073a91]


Fatal server error:

Caught signal 11.  Server aborting


So can anyone offer any advice as to what I may have done wrong in the
building of all this? Do I need to use special anholt or airlied kernel
trees and if so how do I get them with git? Or is it OK to use the main
Linus Torvalds tree for 2.6.28-rc8


Is there anything further I can do to diagnose what's wrong? I'm
guessing one of the components I've got does not inter-work with the
rest but how do I check the various version numbers and identify which
is too old (or too new?)


Should it be the case if I just get a 2.6.28-rc8 kernel and also all the
git repositories listed in the script in (2) above that I should have up
to date copies of everything or are there patches or update versions I
need to pick up from elsewhere?


Cliff Lawson



From: Mateusz Kaduk [mailto:mateusz.kaduk at] 
Sent: 12 December 2008 13:52
To: Cliff Lawson
Cc: xorg at
Subject: Re: Building latest Intel support for 945G


2008/12/12 Cliff Lawson <cliff at> 

	So I used GIT to get a libdrm that did include the linux-source
part of the tree but when I built it the i915.ko did not build and
looking at the Makefile it would appear to be because OS_HAS_GEM was not
defined. It was a search for the solution to that which brought me to a
post in the archive of this mailing list where I realised that a simple
"export OS_HAS_GEM=1" before building was NOT the solution to use.

You dont set that. drm/linux-core is out-dated.
You get correct drm.ko and i915.ko from latest kernel or from
for-airlied branch of eric's tree.

Look at Eric's LJ first case as
You dont need dri2.
And after clone switch to for-airlied branch which is a bit more stable.

I dont know if master xf86-intel does not need xserver 1.6 (here 1.6),
but there is also origin/xf86-video-intel-2.5-branch which should
compile fine with xserver 1.5.3 which is in debian/experiemtal packages
and it should be possible to install it on Ubuntu.

Scanned by MailDefender - managed email security from intY -

No virus found in this incoming message.
Checked by AVG -
Version: 8.0.176 / Virus Database: 270.9.17/1844 - Release Date:
12/12/2008 09:02

Scanned by MailDefender - managed email security from intY -
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Xorg.0.log.cjl2
Type: application/octet-stream
Size: 28835 bytes
Desc: Xorg.0.log.cjl2
URL: <>

More information about the xorg mailing list