intel 855GME

Lukas Hejtmanek xhejtman at
Mon May 21 14:52:31 PDT 2007

On Mon, May 21, 2007 at 10:30:08PM +0100, Leo wrote:
> >> > Just experiment, below doc has more info.
> >> >
> >> >> > linux/Documentation/power/video.txt
> >> 
> >> I tried out every method in this document and none of them
> >> worked. Ideas?
> >
> > Are you using VESA framebuffer? If so, do not use it.
> >
> > Are you able to ping the machine after suspend-to-ram? If not, there is
> > another problem not related to graphics. 
> Fedora is using a new pm-utils and HAL quirk matching framework.

so, how is this related to your problem? What I'm trying to say, avoid such
ugly systems, if s-t-r does not work for you. Preferably, try to boot in the 
text mode only, configure your network. Avoid any boot acpi_sleep parameters.

echo mem > /sys/power/state

After wake up, test whether your machine is still reachable over network. If
so, use ssh to connect to your laptop. Try vbetool post, you should see text
mode with cursor (try to hit enter, if you see nothing just blank screen).

If you succeed with this, s-t-r will work for you. If not, then there is a
problem with another piece of hardware and s-t-r. You may try to remove all
uneeded modules and try it again.

Lukáš Hejtmánek

More information about the xorg mailing list