[x11] Re: build.sh chokes on module x11proto: `automake requires `AM_CONFIG_HEADER', not `AC_CONFIG_HEADER'

John Klingler john at jupiter.com
Tue Mar 20 14:48:43 PDT 2007

Well, ModularDevelopersGuide says automake 1.7 or newer:

        In addition to the minimum requirements listed above, the 
following tools are required for developers:

    * autoconf 2.57 or newer
    * automake 1.7 or newer
    * perl version 5.xx or newer
    * m4 1.4 or newer
    * libtool 1.5 or newer

        As above, known-good versions are available from the extras 
<http://xorg.freedesktop.org/extras/> collection.

On the extras link they have autoconf 2.57 (which I already have) and 
auotmake 1.9.6.  Attempting to
configure automake it says:
       configure: error: Autoconf 2.58 or better is required.
a minor oversight, no doubt.

I'll see if I can find automake 1.7 or thereabouts.



Alex Deucher wrote:

> On 3/20/07, John Klingler <john at jupiter.com> wrote:
>>  automake (GNU automake) 1.6.3
> you need at least 1.9.  See this page for more info:
> http://wiki.x.org/wiki/ModularDevelopersGuide
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20070320/723affa2/attachment.html>

More information about the xorg mailing list