blackscreen with xf86-video-intel-1.9.91

Matthieu Baechler m.baechler at
Sat Mar 10 12:03:53 PST 2007

Le samedi 10 mars 2007 à 11:09 -0800, Keith Packard a écrit :
> On Sat, 2007-03-10 at 17:27 +0100, Matthieu Baechler wrote:
> > Hi all,
> > 
> > I tried last intel driver xf86-video-intel-1.9.91 with
> > on my macbook.
> Can you provide us with more precise model information? Many people have
> run this driver on various macbook models and it has worked for them.

It's a Core 2 Duo model, also known as Macbook2,1, exactly the one you
can buy on at this time.

I forgot to say that I don't use BootCamp on it, so no BIOS emulation is
provided (I boot with rEFIt)

> > Unfortunately, it got a blackscreen at X boot, where only the mouse
> > cursor is visible.
> That's very odd; it doesn't look like the server is changing the LVDS
> mode at all. There are a couple of possible issues; the BIOS sets the
> panel up for spread-spectrum clocking and the X driver does not (we
> cannot detect whether the external spread-spectrum hardware is present).
> > Interestingly enought, after I boot X with the new driver, the old one
> > get the same problem (blackscreen, only mouse cursor visible), although
> > after a fresh boot, the old driver works fine.
> Looking at the output of the server, this doesn't make sense; the server
> leaves all of the registers it knows about in the same state as at
> startup time.

I don't know if it makes sense, but it's what happen.

What additional clues could I give you for your diagnostic ?

Matthieu Baechler <m.baechler at>

More information about the xorg mailing list