Xorg 1.1.1 + Mesa 6.5.2 = White screens with i810 driver and beryl/compiz

Roland Scheidegger sroland at tungstengraphics.com
Mon Jan 8 15:08:25 PST 2007

Colin Guthrie wrote:
> Roland Scheidegger wrote:
>>> I'm using glproto 1.4.7 but have also tried 1.4.8 (heard it's buggy
>>> tho'?)
>> That would be news to me. However, since the protocol number of
>> GLX_EXT_texture_from_pixmap changed between glproto 1.4.7 and 1.4.8 (as
>> it was wrong before), I highly doubt this would work with an old glproto
>> but a new xserver or new mesa (which changed the protocol number at the
>> same time, 2006-09-14). Shouldn't affect the copy path, however, I guess.
> OK, I'll take your word for it. :) I just saw lots of people saying they
> "reverted to older glproto" in lots of posts about having similar problems.
> I have tried recompiling glproto 1.4.8 + Mesa + Xorg 1.1.1 + drivers
> etc. in the past to no avail. Would I have needed to recompile libdrm
> for the updated glproto (cause I didn't!) If so is there anything else I
> should have recompiled too? AFAIK, it doesn't need glproto so I don't
> think this is at fault.
> Does Mesa 6.5.2 *need* glproto 1.4.8? Or will everything "just work"
> provided Mesa, Xserver and driver are all built with the same glproto?
> Thanks for any help.
Actually I don't think this will work at all with xorg 1.1.1 as this has
the old opcodes. Maybe you could patch it, the commit for the xserver
was 05231e336db8f959c15dda518641976f061df1a6. The numbers are present in
all of glproto, xorg server and mesa so supposedly a simple recompile
with the same glproto may not work. Not sure though what the
consequences really are...


More information about the xorg mailing list