XvMC on savage

John Gruenenfelder johng at as.arizona.edu
Mon Jan 8 13:01:03 PST 2007

On Mon, Jan 08, 2007 at 04:35:10PM +0200, Dag Nygren wrote:
>> On 1/8/07, Dag Nygren <dag at newtech.fi> wrote:
>> >
>> > > AFAIK there is no working XvMC for savage.
>> >
>> > I was afraid so. Have to go back to xorg 8.2 then, it works there.
>> >
>> XvMC has never been supported on savage chips.  S3 release some code
>> years ago, but no one could get it to work and it only supported a
>> subset of the twister/prosavage IGP chips.
>It has worked here with my MythTV for about one year, until I some days ago
>upgraded my OS, which forced Xorg 7.1.1 on me.
>The CPU load increased by 40% (absolute) and the picture quality went down 
>a bit.
>The same thing happened with 8.2 without the XVMC part.

I have the same problem with the Savage chipset in my MythTV machine, also in
the same Shuttle box as you.

But from what I can tell there is no XvMC problem becuse there is no XvMC.
Rather, in all the checking I have done it seems to be that Xv is broken.  The
logs say it is fine and all the programs that need Xv get it, but, just as
with your machine, the CPU load is at an unacceptable level.

I'm running Debian and I had Xorg 6.8 or 6.9 under which everything worked
fine.  When Debian/sid moved to X.org 7 I began to have these problems.

I think it might possibly be the fault of bad mtrr settings?  I'm not sure.  I
get several entries in the MTRR table after X starts:

reg00: base=0x00000000 (   0MB), size= 512MB: write-back, count=1
reg01: base=0x1e000000 ( 480MB), size=  32MB: uncachable, count=1
reg02: base=0xd8000000 (3456MB), size=  64MB: write-combining, count=2
reg03: base=0xd0000000 (3328MB), size= 128MB: write-combining, count=3
reg05: base=0xd8000000 (3456MB), size=  64MB: write-combining, count=1

And this error message appears in the console log four times:

mtrr: base(0xd2000000) is not aligned on a size(0x5000000) boundary

But I'm not sure what to correctly set the MTRR to or if it is even wrong.

--John Gruenenfelder    Research Assistant, UMass Amherst student
                        Systems Manager, MKS Imaging Technology, LLC.
Try Weasel Reader for PalmOS  --  http://gutenpalm.sf.net
"This is the most fun I've had without being drenched in the blood
of my enemies!"
        --Sam of Sam & Max

More information about the xorg mailing list