i810 with modesetting won't start.

Mark Beierl mbeierl at signiant.com
Thu Jan 4 17:05:45 PST 2007

I don't know if it'll help, but video ram is specified in kb, like so:

VideoRam 131072
means 128MB.


On Thu, 2007-04-01 at 17:52 -0500, Tim wrote:

> Hey everyone,
> I've recently been trying to use the modesetting branch of the i810
> driver, from git.  I have a ViewSonic monitor that supports 1440x900;
> that's what I need to use.  My video card is an Intel
> 82845G/GL/GE/PE/GV.  I've been reccomended the modesetting driver
> after 915resolution failed... 
> With much work, I finally got the driver to compile with autogen.sh,
> make, and make install.  However, upon restarting my PC and trying to
> run X with the newly compiled driver, I get:
> "Failed to allocate framebuffer.  Is your VideoRAM set too low? 
> Fatal servererror: AddScreen/ScreenInit failed for driver 0"
> I left VideoRam, in my xorg.conf, blank originally, but then tried
> 256--neither worked.  My xorg.conf is attached. (Note that I may have
> left the driver as "vesa" in the .conf; I switched to vesa so I could
> write this message... but nevertheless I HAVE been trying to use the
> driver "i810"). 
> What's going on, has anyone else experienced these problems, how can I
> fix it, etc.
> Thanks!
> -- 
> Tim 
> _______________________________________________
> xorg mailing list
> xorg at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/xorg
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20070104/0542103b/attachment.html>

More information about the xorg mailing list