i810 with modesetting won't start.

Tim tm8992 at gmail.com
Thu Jan 4 14:52:30 PST 2007

Hey everyone,
I've recently been trying to use the modesetting branch of the i810 driver,
from git.  I have a ViewSonic monitor that supports 1440x900; that's what I
need to use.  My video card is an Intel 82845G/GL/GE/PE/GV.  I've been
reccomended the modesetting driver after 915resolution failed...

With much work, I finally got the driver to compile with autogen.sh, make,
and make install.  However, upon restarting my PC and trying to run X with
the newly compiled driver, I get:

"Failed to allocate framebuffer.  Is your VideoRAM set too low?
Fatal servererror: AddScreen/ScreenInit failed for driver 0"

I left VideoRam, in my xorg.conf, blank originally, but then tried
256--neither worked.  My xorg.conf is attached. (Note that I may have left
the driver as "vesa" in the .conf; I switched to vesa so I could write this
message... but nevertheless I HAVE been trying to use the driver "i810").

What's going on, has anyone else experienced these problems, how can I fix
it, etc.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20070104/8d9061e9/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.conf
Type: application/octet-stream
Size: 14079 bytes
Desc: not available
URL: <http://lists.x.org/archives/xorg/attachments/20070104/8d9061e9/attachment.obj>

More information about the xorg mailing list