neomagic blank screen in 16bpp mode

Kacper Wysocki kacperw at
Wed Aug 2 04:16:17 PDT 2006


I have an aging IBM Thinkpad 240 with a Neomagic MagicGraph 128XD
video card onboard running an updated debian sid with 7.0.0.
Recently I updated my system and at the same time added a modeline to
xorg.conf, and now startx gives a blank screen - the machine responds
only to magic sysreq. Switching DefaultDepth to 24 lets me get into X,
however 24bpp causes a very visible slowdown on this machine. I can no
longer watch videos, surf the web or even move windows around without
a visible slowdown - none of these problems were forthcoming in 16bpp.

The vga, vesa and fbdev drivers all work in 16bpp, but they all lack XVideo.
I've tried everything from reverting to my old configuration to
esoteric Device options to disabling the framebuffer device in the
kernel, yet I cannot get 16bpp mode to work with the neomagic driver
any more. I also tried looking for posts by people with similar
problems, but didn't find any.

Is it possible that I somehow damaged 16bpp mode on my video card with
an out-of-spec Modeline? (doesn't make much sense, since fbdev works
in the same mode)

What can be happening? What can I do to debug this problem further?
Running xorg with -verbose 6 doesn't yield any more information than
the logfile already gives as far as I can tell.

My xorg.conf and log files can be found at

these should correspond to a run of X which resulted in a black screen
hang, synced and rebooted with magic sysreq keys.


More information about the xorg mailing list