cursor turns invisible when pressing any of a laptops's special keys

Felix Kühling fxkuehl at
Mon Apr 10 17:32:20 PDT 2006

Am Dienstag, den 11.04.2006, 01:42 +0200 schrieb dark_mail at
> I recently installed Gentoo Linux on a Samsung X20 1730V Laptop.
> I currently use xorg-7.0-r1 together with a recent xfce4 desktop, but the
> problems mentioned below also occur with windowmaker or fvwm.
> When I press one of the special keys on the keyboard, e.g. to show a little
> pictogram of the actual battery state or to swich on/off the touchpad, the
> mouse cursor vanishes or rather turns invisible, as I can still move it
> around and use it. When I move the (invisible) cursor, it shows me the
> pictogram normally supposed to be in the left upper corner at the cursor
> position.
> The cursor turns back to visibility when I move it over an application
> window, be it a console, a browser, gkrellm, just off the root window
> (however, this is not the case when I move the cursor over the xfce panel).

Sounds like your BIOS uses the hardware cursor to display the battery
icon (or other icons). The Xserver has no way of knowing that the cursor
image and position were changed, so the cursor is invisible until the
Xserver uploads a new cursor image. This happens when you move the mouse
over a window, changing the cursor shape.

My Samsung X50 notebook has the same feature. It has a Radeon chip which
has two distinct hardware cursors (one ARGB and one two-colored one).
The one that is used for the icons doesn't interfere with the Xorg ARGB

Looking at the source, the i810 driver seems to support ARGB cursors
too. It uses different hardware cursors depending on whether an ARGB or
a two-colored cursor is used. IOW, try using an ARGB cursor. The BIOS
should leave that one alone. (I don't know how to do that in xfce. Gnome
uses an ARGB cursor by default.)

> And, before I forget to add this, when I don't move the cursor during the
> appearance of the pictogram, I only see pixal garbage in the corner. But
> that's just additional stuff.

I don't quite understand this. Are you saying, if you don't move the
mouse, you see garbage instead of the icon? Then what happens, when you
do move the mouse? Does the garbage move with the mouse position or does
it just disappear? Or is the icon displayed correctly?

> I hope you have an idea what I can do about that problem. I tried turning
> off the hardware cursor, but no change.

Disabling the hardware cursor should help. How did you try disabling it?
Option "SWcursor" "yes" should to the trick.


> The laptop has an Intel 915 graphics module.
> gcc is 3.4.5, glibc is 2.3.5-r3
> I put my xorg.conf into the attachment.
> Maybe it can help you help me :-)
> (Although I have to admit it looks a bit messy for all the stuff I tried to
> solve this and many other major and minor problems of mine.)
> Geetings

| Felix Kühling <fxkuehl at>            |
| PGP Fingerprint: 6A3C 9566 5B30 DDED 73C3  B152 151C 5CC1 D888 E595 |

More information about the xorg mailing list