cursor turns invisible when pressing any of a laptops's special keys

dark_mail at dark_mail at
Mon Apr 10 16:42:58 PDT 2006

I recently installed Gentoo Linux on a Samsung X20 1730V Laptop.

I currently use xorg-7.0-r1 together with a recent xfce4 desktop, but the
problems mentioned below also occur with windowmaker or fvwm.

When I press one of the special keys on the keyboard, e.g. to show a little
pictogram of the actual battery state or to swich on/off the touchpad, the
mouse cursor vanishes or rather turns invisible, as I can still move it
around and use it. When I move the (invisible) cursor, it shows me the
pictogram normally supposed to be in the left upper corner at the cursor

The cursor turns back to visibility when I move it over an application
window, be it a console, a browser, gkrellm, just off the root window
(however, this is not the case when I move the cursor over the xfce panel).

And, before I forget to add this, when I don't move the cursor during the
appearance of the pictogram, I only see pixal garbage in the corner. But
that's just additional stuff.

I hope you have an idea what I can do about that problem. I tried turning
off the hardware cursor, but no change.

The laptop has an Intel 915 graphics module.

gcc is 3.4.5, glibc is 2.3.5-r3
I put my xorg.conf into the attachment.

Maybe it can help you help me :-)
(Although I have to admit it looks a bit messy for all the stuff I tried to
solve this and many other major and minor problems of mine.)


Echte DSL-Flatrate dauerhaft für 0,- Euro*!
"Feel free" mit GMX DSL!

Analog-/ISDN-Nutzer sparen mit GMX SmartSurfer bis zu 70%!
Kostenlos downloaden:
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.conf
Type: application/octet-stream
Size: 16087 bytes
Desc: not available
URL: <>

More information about the xorg mailing list