Xgl is no longer giving me the COMPOSITE extension....

Colin Guthrie xorg at colin.guthr.ie
Mon Apr 10 15:21:22 PDT 2006


I used to have Xgl working quite nicely but when I tried to update 
recently, I've run into problems.

Everything is compiled up and running at the moment, but the trouble is 
I do not seem to be getting the COMPOSITE extension from Xgl.

I am definately running Xgl (and the underlying Xorg on display 93):

[colin at jimmy ~]$ ps auxf | grep Xgl
root      8982  5.1  5.7 120008 74396 ?        SL   23:06   0:27      \_ 
/home/colin/xgl/prefix/bin/Xgl -audit 0 -br -accel glx:pbuffer -accel xv:fbo
root      8988  0.2  0.6  48980  8780 tty8     SLs+ 23:06   0:01      | 
   \_ /usr/X11R6/bin/Xorg -br -auth /tmp/.Xgl-auth-t6IRVO -nolisten tcp 
:93 -terminate

I am thinking that the problems may be related to my use of my system's 
Xorg as the underlying platform rather than a more recent CVS build of 
Xorg? Like I say it all worked before but now it doesn't.

When I try and run compiz, it complains that it has no composite extension.

xdpyinfo seems to confirm that it is indeed not available.

I don't seem to have a log file for Xgl so cannot see what more is 
happening easily...

I am using Nvidia drivers. Tried with various settings of the composite 
extension enabled/disabled in xorg.conf (it always seems to enable this 
extension anyways as it is built in....) and with the nvidia option for 
allowing GLX with composite but to no avail.

Any help would be appreicated... I can easily supply more info if needed.

Many thanks..



|     Colin Guthrie      |
| xorg(at)colin.guthr.ie |
| http://colin.guthr.ie/ |

More information about the xorg mailing list