two problems about xorg 6.8.2 in lfs

paradox algorist2000 at
Wed Jun 22 01:48:27 PDT 2005

I download the Xorg 6.8.2 sources,and compile them  in
LFS 6.0 Environment (kernel is 2.6.8, gcc version is
3.4.1) in two machines, one is using AMD Thunderbird
CPU and ATI rage128 cards, the other is using Intel P4
CPU, Intel i865 mainboard,ps/2 mouse and keyboard.

the ~/.xinitrc is like that:

# Begin .xinitrc file
xterm -g 80x40+0+0 &
xclock -g 100x100-0+0 &
# end .xinitrc

In AMD machine, I can run startx, and process some X
application as firefox, xpdf, etc.but in Intel
machine, when I run X -config to make test,I can enter
the graphics interface and see the mouse cursor,but i
can't switch in the text console,press ctrl-f1 causes
the mouse cursor changes to a big white square.running
startx get same result.

In Xorg.0.log, i can see these:

(EE) I810(0): I830 Dma Initialization Failed
(II) I810(0): [drm] dma control initialized, using IRQ
(EE) I810(0): [drm] Failed to initialized agp heap

with another linux system in this machine using
XFree86-4.3.0, I can't find those errors.

what's the problem?

another problem happened in both machines, It take me
45 seconds before I enter the graphics mode after I
run startx. the error messages from console is:

hostname: Host name lookup failure
_XSERVTransSocketOpenCOTSServer: Unable to open socket
for inet6
_XSERVTransOpen: transport open failed for
_XSERVTransMakeAllCOTSServerListeners: failed to open
listener for inet6

then the system enter the graphics mode quickly.
It seems the system spend too much time to wait for
There are no ipv6 modules in my kernel.
How can I solve the problems?

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the xorg mailing list