Screen stays blank when exiting X (i810)

Alan Hourihane alanh at
Thu Jun 9 06:10:44 PDT 2005

On Thu, Jun 09, 2005 at 03:04:10PM +0200, Michael Voucko wrote:
> Hi,
> I'm stuck with running Xorg-6.2.8 on my laptop (Lifebook S-6010).
> (I'm pretty new to the whole X thing so please bear with me)
> Here is what I did.
> - installed Xorg-6.2.8 (on a fresh FreeBSD 5.4 if it matters?)
> - ran 'Xorg -configure'
> - copied the newly created xorg.conf to /etc/X11
> - tested xorg.conf with 'Xorg -config /etc/X11/xorg.conf'
> Everything worked fine.
> But when I try to use KDE or simply put 'xterm' in my .xinitrc there is no 
> way to exit the X server and return to the console - the screen would 
> flicker two more time and afterwards stay black and blank. The keyboard 
> does not allow me to type to the console - but is still operational as I'm 
> able to switch to another virtual console and can blindly enter something 
> like 'reboot' to recover from the dead screen.
> Observable difference in the logfile is
> * last entries in Xorg.0.log when exiting 'Xorg -config /etc/X11/xorg.conf'
> (WW) I810(0): Setting the original video mode instead of restoring
>         the saved state
> (WW) I810(0): Successfully set original devices
> (II) I810(0): xf86UnbindGARTMemory: unbind key 5
> (II) I810(0): xf86UnbindGARTMemory: unbind key 1
> (II) I810(0): xf86UnbindGARTMemory: unbind key 3
> (II) I810(0): xf86UnbindGARTMemory: unbind key 4
> (II) I810(0): xf86UnbindGARTMemory: unbind key 2
> * last entries in Xorg.0.log when exiting KDE or xterm
> (WW) I810(0): Setting the original video mode instead of restoring
>         the saved state
> I tried some of the options available for i810 but either I didn't choose 
> the right combination or they dont make any difference for my situation.
> I started out with checking the FreeBSD specific mailinglists and archives 
> but did not find any explanation or solutions. So I hope that this is the 
> right spot to ask this question.
> Does anybody know what the problem is or can point me in the right 
> direction?
> Is there more information I can provide to track down the problem 
> (xorg.conf is attached)?


You could try adding the option ...

	Option "VBERestore" 

and see if that helps. If not, then you might need to build the latest
driver from CVS.


More information about the xorg mailing list