Bug#783705: xserver-xorg-video-radeon: Weird X wakeup problem since Jessie upgrade

Steve McIntyre steve at einval.com
Wed May 6 06:12:22 PDT 2015

On Tue, May 05, 2015 at 09:06:40AM -0400, Alex Deucher wrote:
>On Wed, Apr 29, 2015 at 7:45 AM, Steve McIntyre <steve at einval.com> wrote:
>> Package: xserver-xorg-video-radeon
>> Version: 1:7.5.0-1
>> Severity: normal
>> Hi folks,
>> I upgrade my main office desktop to Jessie on Monday, and just about
>> evrrything worked really well - just half a dozen oro so config files
>> needed merging with new upstream etc. Painless!
>> However, I'm now seeing a really odd problem with X on my
>> machine. I've got an AMD graphics card, which Xorg.0.log tells me is a
>>  RADEON(0): Chipset: "PITCAIRN" (ChipID = 0x6810)
>> and a DP+ connection to a lovely 27" NEC monitor. It works just fine
>> when I'm using it, *but* when I leave it overnight and come in the
>> next morning it doesn't want to wake up properly. I'm locking the
>> screen with Xscreensaver and then turning off the monitor as I leave.
>> In the morning, I turn on the screen and I don't get a display at
>> all. I've wiggled the mouse, hit numlock on the keybard (the numlock
>> led illuminates fine), etc., but no display. I've seen this kind of
>> thing happen in the past on some machines, so I switch to VT1 and back
>> to see if that helps. Still no display at all, either on console or
>> under X. I log in remotely and I can see that the Xorg.0.log file has
>> been updated with mode lines for the monitor, suggesting things have
>> just woken up fine. But still no display.
>> Here's the really weird thing: at this point, the monitor has
>> basically locked up. It won't respond to the power/input/menu butttons
>> at all, and is still showing the blue LED that says "I have signal"
>> rather than switching to the amber "no signal" warning. Therefore, I
>> can only assume there's a problem here with some weird invalid DP
>> signal being produced.
>> Yesterday, I gave up and rebooted after a few minutes - I had work to
>> do. Today, I started searching for any other reports like this using
>> my laptop. About ten minutes later while I was doing this
>> (approximately, wasn't paying massive attention at this point), my
>> desktop screen suddenly came to life and now it's working OK.
>> I have no idea of where to even start debugging this. Help!
>If this is a regression, what previous version was working correctly?

I was using an up-to-date wheezy installation previously, so that
would be 1:6.14.4-8.

>Does the problem only happen when you physically power off the

Ah, yes! In fact, it's the act of physically powering off the monitor
that's the problem here. I can reproduce immediately by doing
that. Last night, I locked the screen and left the monitor on and
things were still working fine this morning when I came in.

>Does it come back ok when you let dpms kick in?

Pass - I disabled dpms ages ago for unrelated reasons...

>How about when you physically disconnect the monitor from the

I tried that - if I unplugged the cable from the monitor, the monitor
started responding to button presses ok but as soon as I reconnected
it locked up again and still no display.

>Also, what screensavers are you using?  There may be a problematic GL
>screensaver that's causing a GPU lockup.  Can you try forcing a
>single known stable screensaver?

I just use "bumps" under xscreensaver, and I've had that configured
for years.

Steve McIntyre, Cambridge, UK.                                steve at einval.com
Can't keep my eyes from the circling sky,
Tongue-tied & twisted, Just an earth-bound misfit, I...

More information about the xorg-driver-ati mailing list