Bug#783705: xserver-xorg-video-radeon: Weird X wakeup problem since Jessie upgrade

Steve McIntyre steve at einval.com
Wed May 6 06:26:40 PDT 2015

On Tue, May 05, 2015 at 01:55:16PM +0200, Julien Cristau wrote:
>On Tue, May  5, 2015 at 12:40:54 +0100, Steve McIntyre wrote:
>> On Wed, Apr 29, 2015 at 12:45:29PM +0100, Steve McIntyre wrote:
>> >
>> >In the morning, I turn on the screen and I don't get a display at
>> >all. I've wiggled the mouse, hit numlock on the keybard (the numlock
>> >led illuminates fine), etc., but no display. I've seen this kind of
>> >thing happen in the past on some machines, so I switch to VT1 and back
>> >to see if that helps. Still no display at all, either on console or
>> >under X. I log in remotely and I can see that the Xorg.0.log file has
>> >been updated with mode lines for the monitor, suggesting things have
>> >just woken up fine. But still no display.
>> Similar problem this morning. I've found that using xrandr to disable
>> and re-enable the DisplayPort output I'm using helps - the display
>> comes back. Until xrandr segfaults, anyway - see separate bug.
>> Something weird in the card state, I guess?
>Sounds likely.  If this still happens with linux 4.0, can you report
>this upstream at
>and let us know the bug number?

OK. New kernel didn't help at all. Bug filed:


Steve McIntyre, Cambridge, UK.                                steve at einval.com
< Aardvark> I dislike C++ to start with. C++11 just seems to be
            handing rope-creating factories for users to hang multiple
            instances of themselves.

More information about the xorg-driver-ati mailing list