ati rage mobility-p crash

Connor Behan connor.behan at
Wed Jan 29 19:00:24 PST 2014

On 29/01/14 06:02 PM, rwas <rbtwas at> wrote:
> Hello,
> I've had this bug since I upgraded to OS 12.3. When I run anything with Java
> the X server crashes. Apparently this is an old bug. I've seen 
> references to it
> going back past 2011. I've searched and can't find any activity on this 
> issue.
> Do I submit a new bug?
First try compiling xf86-video-mach64 from git. The second most recent
commit sounds relevant to your problem.

If you're looking for workarounds, you can always try disabling EXA in
your xorg.conf. It is probably okay just to disable the Composite /
RENDER part with Option "ExaNoComposite" "true".
> I'd be happy to look into fixing the driver myself but there appears to 
> be very
> little info on how one get'started into X driver development. Help there 
> would be
> appreciated as well...
> I've tried using the "xf86-video-ati-7.2.0" driver but this does not 
> solve the problem.
The best way is to go through the git history. You should find a series
of commits by George Sapountzis adding EXA support to mach64. I added it
a year and a half ago to r128 and was only able to do so by reading
these commits and a bunch in the radeon driver.

The log file should probably go in a pastebin next time.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 555 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the xorg-driver-ati mailing list