Bug#721796: xserver-xorg-video-radeon: X not starting anymore after upgrade

Julien Cristau jcristau at debian.org
Wed Sep 4 13:41:56 PDT 2013

On Wed, Sep  4, 2013 at 22:32:12 +0200, Eloi Notario wrote:

> El Dimecres, 4 de setembre de 2013, a les 12:47:32, Michel Dänzer va escriure:
> > [...]
> > 
> > Looks like the radeon kernel module doesn't get loaded before X starts.
> > Current upstream xf86-video-ati only works with the radeon kernel module
> > loaded in KMS mode.
> > 
> > Maybe some leftover from fglrx is preventing the radeon kernel module
> > from getting loaded.
> I have no fglrx packages installed, however I purged them to try to get rid of 
> possible leftovers. That didn't work.
Did you reboot after purging the fglrx stuff?

> Then I manually loaded the radeon module using modprobe, expecting some sort 
> of error or more clues, but it worked. After this and a kdm restart, 
> everything seems back to normal.
> For some reason, xorg does not load (or tries to and fails) the readon kernel 
> module. I added radeon to /etc/modules so it's loaded at every startup, which 
> it does earlier at boot, noticeable due to the smaller console font.
> If you consider appropiate, I am willing to do some tests on my machine to 
> check why the radeon module is not automatically loaded, but please tell me 
> how to proceed (I am almost clueless about kernel whereabouts). If not, for me 
> the problem is solved and the bug may be closed.
Check for any blacklist in /etc/modprobe.d/ maybe.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://lists.x.org/archives/xorg-driver-ati/attachments/20130904/eda89a30/attachment.pgp>

More information about the xorg-driver-ati mailing list