Bug#721796: xserver-xorg-video-radeon: X not starting anymore after upgrade

Michel Dänzer daenzer at debian.org
Wed Sep 4 03:47:32 PDT 2013

On Mit, 2013-09-04 at 08:39 +0200, Eloi Notario wrote:
> Package: xserver-xorg-video-radeon
> Version: 1:7.2.0-1
> Severity: important
> Dear Maintainer,
> Since last upgrade from 1:6.14.4-8 to 1:7.2.0-1 X does not start for me.
> I've tried moving my custom xorg.conf out of the way but to no avail.
> I've also tried using an old linux kernel, also unsuccessfully, that's 
> why I'm filing the bug here.
> Please tell me if you need more info, however my availibity may be
> scarce for the next week. The comments on xorg.conf are from 2010 where
> I had another issue and tried some alternative configurations, I tested
> the other Screen directives on ServerLayout, they didn't work either
> but for reasons apparently unrelated (fglrx not supporting my chipset
> anymore, vesa complaining about "No matching modes").
> The computer is a 5-year-old Samsung R60+ laptop using a Radeon X1250.


> [  1073.294] (II) [KMS] drm report modesetting isn't supported.


> DRM Information from dmesg:
> ---------------------------
> [    1.278892] Linux agpgart interface v0.103

Looks like the radeon kernel module doesn't get loaded before X starts.
Current upstream xf86-video-ati only works with the radeon kernel module
loaded in KMS mode.

Maybe some leftover from fglrx is preventing the radeon kernel module
from getting loaded.

Earthling Michel Dänzer           |                   http://www.amd.com
Libre software enthusiast         |          Debian, X and DRI developer

More information about the xorg-driver-ati mailing list