no HDMI audio, no display with

Alex Deucher alexdeucher at
Tue Aug 6 06:36:21 PDT 2013

On Sat, Aug 3, 2013 at 4:08 PM, Willem van Asperen
<willem at> wrote:
> Hi All,
> I am running Archlinux (kernel 3.10.3) with ati driver 1:7.1, on an ASRock
> E350M1 Mini ITX board that has a Radeon HD 6310 on-board. (From the
> evergreen family, feature matrix shows "DONE" at HDMI audio). Further specs:
> processor: AMD Fusion E-350
> chipset: AMD A50M (Hudson-M1)
> Attached to the board is my TV set, via HDMI.
> Vanilla install works fine, except: no audio via HDMI.
> The standard alsa device is configured as card 0, device 0. But poking
> around (aplay -l, cat /proc/asound/cards) shows me this should be card 0,
> device 3. That's something that needs fixing. But
> mplayer -ao alsa:device=hw=0.3 <some file>
> returns no errors but I hear no sound...
> Reading the (excellent) arch wiki
> ( I was recommended
> to add to my kernel parameters. Without it, I see that I
> /sys/.../parameters/audio = 0. Setting the kernel parameter does flip this
> parameter into 1...
> But: as soon as the kernel loads with this parameter set, the screen goes
> blank with no signal detected by my TV. The system continues booting as per
> normal. Logging in through ssh and trying to play the same audio file: still
> no sound from my TV set. Switching the TV off and back on or unplugging and
> plugging back in (all this while mplayer runs), still no sound.
> Just for fun: also setting as kernel parameter does not help.
> Same thing...
> When I run mplayer, nothing awkward shows up in journalctl -f
> Any clue as to what to try next?

You might be hitting the same issue as this bug:


More information about the xorg-driver-ati mailing list