[Bug 28422] X freese in many cases

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Jun 30 16:54:54 PDT 2010


--- Comment #55 from DEMAINE Benoit-Pierre <benoit at demaine.info> 2010-06-30 16:54:54 PDT ---
I started Archlinux with the gentoo XEN kernel ( z01 kernel config ) (because I
was too lame to try to understand how to compile a kernel under this distro),
and I could run the Xinerama configuration (Arch 02 xorg.conf ... and I even
forgot to pass LIBGL_ALWAYS_SOFTWARE=1). It was working like a charm. 6
monitors exactly as I want. Straight away.

I also tried the accelerated configuration (Arch 01 xorg.conf), and, i was not
surprised to see it did not work (missing or uncompatible low level DRI/DRM / i
don't want to know what ... drivers).

So, the problem is NOT the kernel, kernel version, or kernel configuration.
2.6.34-xen-Gentoo-uranus-1-19 (or maybe it was 1-15 last time) is perfectly
suitable for multiple card use.

Arch is using X.Org X Server (1.8.2 RC 2)
My Gentoo is actually using (1.8.2 RC 2)

The problem is not:
- kernel
- xorg.conf (last night, I was using the working conf from Arch)

Very few things left could differ.

I also tried to use Arch 02 xorg.conf on kernel
2.6.34-gentoo-r1-Gentoo-uranus-1-20 (which is not XEN capable; thus, xend
failed to start), and it also freesed. So, the issue is not xend being started.

Few things left:
- libc
- X drivers
- (x)randr and mesa versions ...

and X still does not say why it's crashing.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the xorg-driver-ati mailing list