(Crowd funded) fix for SiS 671/771 video cards

Pander pander at users.sourceforge.net
Sat May 11 03:52:48 PDT 2013

On 05/10/2013 08:13 PM, Tormod Volden wrote:
> On Fri, May 10, 2013 at 11:04 AM, Pander wrote:
>>> On 05/07/2013 09:24 PM, Connor Behan wrote:
>>>> SiS drivers support EXA and will probably use that by default when
>>>> you start one of the newer Xservers that lacks XAA. This could
>>>> easily crash if the SiS EXA hooks haven't been updated in awhile so
>>>> that's why I suggested "NoAccel" to help diagnose the problem.
> Connor, first, thanks a lot for caring for these old drivers. A lot of
> people are still using their old laptops and run the latest Linux
> distributions on them.
> Thanks especially for the hint you gave earlier in this thread: "EXA
> callbacks that use the devPrivate.ptr of a pixmap." I am trying to
> keep the savage driver working, but I don't have the capacity to
> follow xorg development in detail. Recently an EXA problem came up for
> which I had no clue. Reading your hint was enough to guide me in the
> right direction and now I believe I have fixed it with a one-liner
> change.
>> Xorg works but when I press CTRL+ALT+F1 I get a screen with an unusable
>> screen. I see a small part of Xorg repeated a lon on the left side and
>> on the right side many different colors. This part works with the older
>> SiS driver for other cards.
> Pander, does console switching work with the vesa driver? It doesn't
> on my savage card, so I wonder if it is a more general non-KMS
> problem. You say it works with the older SiS driver though, was that
> also on the latest xserver?

Yes it worked and was on Ubuntu 13.04 xorg 2:1.13.3-0ubuntu6

Also, when booting and no X has been loaded the screen also works.

> Regards,
> Tormod

More information about the xorg-devel mailing list