[PATCH:libpciaccess 1/3] Enable boot_vga support only if WSDISPLAYIO_GET_BUSID is defined.
walter harms
wharms at bfs.de
Wed Jun 12 06:22:37 PDT 2013
Am 12.06.2013 13:43, schrieb Thomas Klausner:
> Fixes build on NetBSD-5.
> ---
> src/netbsd_pci.c | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/src/netbsd_pci.c b/src/netbsd_pci.c
> index 3566d7b..c9bd052 100644
> --- a/src/netbsd_pci.c
> +++ b/src/netbsd_pci.c
> @@ -248,6 +248,7 @@ pci_device_netbsd_write(struct pci_device *dev, const void *data,
> return 0;
> }
>
> +#if defined(WSDISPLAYIO_GET_BUSID)
> static int
> pci_device_netbsd_boot_vga(struct pci_device *dev)
> {
IMHO you can improve readability when you provide a dummy function for pci_device_netbsd_boot_vga()
like
#if defined(WSDISPLAYIO_GET_BUSID)
static int
pci_device_netbsd_boot_vga(struct pci_device *dev)
{
.....
#else
static int
pci_device_netbsd_boot_vga(struct pci_device *dev)
{
return 1;
}
#endif
so there is no need to modify .boot_vga
just my 2c,
re,
wh
> @@ -284,6 +285,7 @@ pci_device_netbsd_boot_vga(struct pci_device *dev)
>
> return 1;
> }
> +#endif
>
> static void
> pci_system_netbsd_destroy(void)
> @@ -518,7 +520,11 @@ static const struct pci_system_methods netbsd_pci_methods = {
> .read = pci_device_netbsd_read,
> .write = pci_device_netbsd_write,
> .fill_capabilities = pci_fill_capabilities_generic,
> +#if defined(WSDISPLAYIO_GET_BUSID)
> .boot_vga = pci_device_netbsd_boot_vga,
> +#else
> + .boot_vga = NULL,
> +#endif
> };
>
> int
More information about the xorg-devel
mailing list