libX11 build error

Deniz Fer Deniz.Fer at
Wed Nov 24 00:05:23 PST 2010

libX11, I'm trying to compile, is from the git tree and 1.4.0. I checked the Makefile it's as same as the one you wrote.
My previous mail had the output of the compiling script which also includes the output of configure command. There appears to be no error but a lot of warnings which I couldn't understand. I have added the config.log and config.status files in the attachments.

I also tried to issue the command you have mentioned before, it executes without any error (so the commands used are all valid) but the XLC_LOCALE file it creates is empty (probably because I did not edit any environment variables).

Thank you for your help,

From: Gaetan Nadon [mailto:memsize at]
Sent: Tuesday, November 23, 2010 5:03 PM
To: Deniz Fer
Cc: Jeremy Huddleston; Osman Karpuz; xorg at
Subject: RE: libX11 build error

On Tue, 2010-11-23 at 10:29 +0200, Deniz Fer wrote:

Hi again,

I have collected the logs.

libX11_compile_log has the output of the following command(I guess this has much information):

./util/modular/ --clone -p --autoresume built.modules /home/yaltes/Desktop/xorg

libX11_V1_log0 has the output of "make V=1" after "make clean"(in libX11 directory).

On a working build, the following command is issued:

/usr/bin/cpp -undef -traditional -DWCHAR32=1 < am_ET.UTF-8/XLC_LOCALE.pre | sed -e '/^#  *[0-9][0-9]*  *.*$/d' -e '/^#line  *[0-9][0-9]*  *.*$/d' -e '/^[         ]*XCOMM$/s/XCOMM/#/' -e '/^[         ]*XCOMM[^a-zA-Z0-9_]/s/XCOMM/#/' -e '/^[         ]*XHASH/s/XHASH/#/' -e 's,X11_LOCALEDATADIR,/home/nadon/xorg/src/share/X11/locale,g' -e '/\@\@$/s/\@\@$/\\/' > am_ET.UTF-8/XLC_LOCALE

It looks like the entire command is missing which comes from the Makefile target:


        @$(MKDIR_P) $(@D)


RAWCPP = /usr/bin/cpp

RAWCPPFLAGS = -undef -traditional



CPP_SED_MAGIC = $(SED) -e '/^\#  *[0-9][0-9]*  *.*$$/d' \

                       -e '/^\#line  *[0-9][0-9]*  *.*$$/d' \

                       -e '/^[         ]*XCOMM$$/s/XCOMM/\#/' \

                       -e '/^[         ]*XCOMM[^a-zA-Z0-9_]/s/XCOMM/\#/' \

                       -e '/^[         ]*XHASH/s/XHASH/\#/' \

                       -e 's,X11_LOCALEDATADIR,$(X11_LOCALEDATADIR),g' \

                       -e '/\@\@$$/s/\@\@$$/\\/'

What is the version of libX11?
Any warnings during configuration?
Can you post config.log config.status?



-----Original Message-----

From: Jeremy Huddleston [mailto:jeremyhu at]

Sent: Monday, November 22, 2010 7:13 PM

To: Deniz Fer

Cc: xorg at<mailto:xorg at>; Osman Karpuz

Subject: Re: libX11 build error

A full build log would be helpful.

On Nov 22, 2010, at 07:57, Deniz Fer wrote:

> Hello,


> I have a computer with CentOS 5.5 installed. My current Xorg version is attached and I want to upgrade to Release 7.5 (MPX being the main reason for the upgrade).


> I have followed every instruction in the wiki. I used manuel build with Peter's instructions in FAQ, I have failed. I used jhbuild (after upgrading python and dbus), I have failed. Every time I have failed I get the same error which is "am_ET.UTF-8/XLC_LOCALE: command not found". It's a module in libX11, nls. I also tried to use -disable-xlocale with no success. After some research it appears that after configure, Makefile has an error in it self and it tries to use a command that is not present in my system.


> Probably I'm missing some other upgrade but couldn't find what it might be. If anyone encountered this problem or something similar please help. Thank you for your time.


> Kind regards,

> Deniz FER


> Yenişehir Mah.

> Lale Sk. No:8

> 34891-Pendik İSTANBUL

> Tel: +90 216 482 3060  x.241

> Fax:+90 216 482 3051


> <xorg-version.txt>_______________________________________________

> xorg at<mailto:xorg at>: X.Org support

> Archives:

> Info:

> Your subscription address: jeremyhu at<mailto:jeremyhu at>


xorg at<mailto:xorg at>: X.Org support



Your subscription address: memsize at<mailto:memsize at>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 65661 bytes
Desc: config.log
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.status
Type: application/octet-stream
Size: 42296 bytes
Desc: config.status
URL: <>

More information about the xorg mailing list