error: possibly undefined macro: AC_CHECK_FILE in doc/xorg-docs

Dennis Clarke dclarke at
Wed Aug 28 22:02:16 UTC 2019

On 8/26/19 4:01 PM, Alan Coopersmith wrote:
> On 8/25/19 9:27 PM, Dennis Clarke wrote:
>> warning: PKG_PROG_PKG_CONFIG is m4_require'd but not 
>> m4_defun'd
> That sounds like you're missing pkg.m4 from pkg-config.
>> configure:11098: error: possibly undefined macro: m4_ifval
>>        If this token and others are legitimate, please use 
>> m4_pattern_allow.
>>        See the Autoconf documentation.
>> configure:11102: error: possibly undefined macro: AC_CHECK_FILE
> Those come from autoconf itself - either the lack of the other 
> definitions left
> the m4 parser in a state it couldn't recover from, or your autoconf 
> installation
> is unwell.

Thank you Alan for the help!  Good to see you are still out there doing
all things X-like.

I found the issue and had to install a few things into Debian stable and
now I recall the process from years ago. It is very much like pushing a
little red wagon up a hill. When the wagon hits a stone and stops I have
to deal with the little stone and then go back to pushing up the hill
until all the little stones have been cleared out of the way.

At the moment the show stopper is :

Checking for function "dlopen" : NO
Library dl found: YES
Checking for function "dladdr" with dependency -ldl: YES
Checking for function "dl_iterate_phdr" : YES
Checking for function "clock_gettime" : YES
Dependency zlib found: YES 1.2.11
Dependency threads found: YES
Checking for function "pthread_setaffinity_np" with dependency threads: YES
Checking for function "pthread_setaffinity_np" with dependency threads: NO
Dependency expat found: YES 2.2.6
Library m found: YES
Message: libdrm 2.4.99 needed because amdgpu has the highest requirement
Dependency libdrm_intel found: YES 2.4.99
Dependency libdrm_amdgpu found: YES 2.4.99
Dependency libdrm_radeon found: YES 2.4.99
Dependency libdrm_nouveau found: YES 2.4.99
Dependency libdrm found: YES 2.4.99
Found llvm-config '7.0.1' NO (needed >= 8.0.0 )
Dependency LLVM found: NO (tried config-tool) ERROR:  Dependency "llvm" not found, tried config-tool

A full log can be found at 
/opt/xorg/build/xorg/mesa/mesa/builddir/meson-logs/meson-log.txt "meson" failed on mesa/mesa error processing:  "mesa/mesa"

However :

styx$ dpkg-query -l | grep 'llvm' | cut -c1-71
ii  libllvm7:amd64                        1:7.0.1-8
ii  llvm                                  1:7.0-47
ii  llvm-7                                1:7.0.1-8
ii  llvm-7-dev                            1:7.0.1-8
ii  llvm-7-runtime                        1:7.0.1-8
ii  llvm-dev                              1:7.0-47
ii  llvm-runtime                          1:7.0-47

So what is this stone in the path this time as I can not figure it out.


More information about the xorg mailing list