Cannot create xkb layout - Possible bug and regression in xkbcomp or xkb?

cheater cheater cheater00 at
Wed Dec 5 04:45:15 PST 2012

I have recently tried updating a layout I have, called us_split. In
its basic form it's like the us qwerty layout with a small mod. This
is to make a specific keyboard (Logitech k400) more usable. The idea
is to make the up arrow into right shift, down and right arrows into
right ctrl, right control into right alt, and left arrow into left
meta. It makes much more sense when you see the keyboard:

I call the new fork us_split_k400. It can be found at:

the original can be found at:

the specific diff can be found at:

I have found the following issues:

1. Even without the changes above, my layout has regressed. In
specific: us_split hard-wires caps to esc. That is, if you press the
button to the left of A, you get esc. This isn't recognized anymore. I
believe on this pc I have first installed the layout while running a
fairly early beta of ubuntu 12.04. I have just reinstalled it (using
python and the esc key to the left of A is simply gone. On
the other hand, mapping compose onto the original esc key to the left
of F1 works as it did before.

2. in us_split_k400, the arrows and right control don't bear
remapping. In specific, only setting the right arrow to control_r
worked. The rest didn't do anything. However, the layout worked
correctly in a tty after I did sudo loadkeys us_split_k400.

3. The caps-as-esc key developed VERY weird behaviour: it was esc AND
caps at the same time. So if you pressed it, you got esc, but the
status of caps lock changed as well. Again, this worked under

I would appreciate any and all tips. This is driving me nuts, and I
think it might be representative of a deeper problem. I have no idea
where to start, but if anyone would like me to perform any tests I'd
love to help out.


More information about the xorg mailing list