High /usr/bin/X CPU Usage

Robert Massaioli robertmassaioli at gmail.com
Tue Sep 6 23:49:17 PDT 2011

Hi Tormod and Chris,

Thankyou for the great responses so far! But unfortunately still no luck.
Let me explain the results of what happened after I tried what was

I tried looking into the CPU and GPU issues that people were mentioning but,
after having the computer running for 8 hours straight the CPU was sitting
at 40C and the Graphics GPU was sitting at 27C (C = degrees Celsius). I put
a lot of effort into making sure that my entire setup stayed cool and it
seems to be doing that nicely. So I think I can rule out overheating as the

> Are you using the proprietary nvidia driver? Or nouveau or nv? The
> best is if you can try the latest development version of your
> distribution and file a bug there if you can reproduce it.

I am currently running the latest version of the nvidia drivers that I
downloaded from Nvidias own website. (Before that I tried the latest Nvidia
drivers that were packaged with Ubuntu and I moved away from them because
the problem persisted). I just checked if there are any more recent drivers
that I could be using and there are not: I am using the latest Nvidia

> Try also running without xmonad (not that I really suspect xmonad is
> at fault). At the gdm login screen you can choose a "failsafe
> terminal" as session, which will give you an xterm without any window
> manager. Alternatively you can switch to a virtual console, stop X and
> gdm by running "sudo stop gdm" and then start a bare xterm session by
> running "xinit" - as long as you have not created a .xinitrc to start
> other stuff of course.

Well I ran a failsafe X session and the problem did not appear after an hour
or two of use, but that does not really mean anything because sometimes it
does not happen for hours; I still do not know how force the problem to
happen (I do not know how to reproduce it) just that it happens in normal
operation. I will try this again soon.

> You said the problem appears after some time. Does a restart of the
> xserver fix it temporarily again or do you need to reboot?

A restart of the xserver seems to fix the problem without the need for a
hard reboot. When I encountered the problem again just minutes ago (after
about six hours of waiting) I shutdown gdm with sudo stop gdm and then ran
xinit it all came back up without any problems and without X using up alot
of my CPU. I do not know what that means but it does answer your question.
So yes, rebooting the machine works but restarting the xserver also works

Thanks and I hope this begins to lead us in the right direction,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20110907/fe1148ee/attachment.html>

More information about the xorg mailing list