High /usr/bin/X CPU Usage

Robert Massaioli robertmassaioli at gmail.com
Mon Sep 5 17:46:23 PDT 2011

Hi XOrg Mailing List,

In a nutshell: I am having issues with /usr/bin/X taking up way too much CPU
and, when it does start to use more CPU, my entire user experience becomes
quite laggy. I have tried really hard to solve the problem on my own but I
was unable to find a solution so I have finally decided that it is time for
me to ask this mailing list for help. That is the fundamental problem, the
rest of this post deals with how it happens, what I am running and what I
have already tried. I could use any help I can get so thank you for reading.

This link points to a screenshot of htop running showing the constant high
40-60% CPU usage that /usr/bin/X now sits at: http://i.imgur.com/mRIzG.png

My computer is quite powerful and should easily be able to handle any load
that any part of linux can throw at it. I have a Quad Core i2500k CPU, an
NVIDIA 560 Ti Graphics Card and 8GB RAM, so no hardware bottlenecks thats
for sure (and my Windows Partition runs like a breeze; which proves that the
hardware seems to be solid). However, with that in mind this is what

   1. Start computer, everything is working fine, /usr/bin/X is behaving
   normally. I can play and watch videos with no lag at all.
   2. Wait some undefined period of time and just work on stuff (I don't
   actually know how to reliably reproduce the problem but it does happen every
   single time I use my linux partition).
   3. Watch one of my CPU's spike to an average of 50% and keyboard
   responsiveness drop to the point where I can notice the lag in response
   time. Video playback also becomes impossibly slow at this point.

I would not have thought that the keyboard would be an issue but it is
lagging so I have a Razer Acosta keyboard if that helps.

In short, I have no idea what is causing the problem, on the software side I
am running:

$ uname -a
Linux ShhnapDesk 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:07:17 UTC
2011 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/lsb-release
$ xmonad --version
xmonad 0.9.2

My window manager is XMonad as you can see from above and I am also running
XMobar (0.13) through that. I have tried:

   - Asking for help elsewhere:
   - Uninstalling Flash because I read that it might be the problem.
   - Using Firefox instead of Google Chrome (I found that chrome had some X
   issues in the past)
   - Closing every single X program (bar XMonad) to see if /usr/bin/X would
   start behaving again.

But none of those troubleshooting attempts worked out for me.

I do not know what else to do other than read through the entire codebase of
X and try and reverse engineer where my problem lies. If anybody has any
suggestions then please make them and any extra information that you happen
to require I will be more than happy to provide. This problem is
significantly hindering my Linux joy and I love Linux. I use it for
everything and have done so for the last three years.

Thanks in advance for any and all help,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20110906/5a026792/attachment.html>

More information about the xorg mailing list